NVIDIA – Beta Driver 361.16 Breaks Plasma/KDE5..

Updated the tests system to the latest ‘beta’ driver 361.16, and this broke Plasma/KDE5..    This driver is supposed to introduce the ‘vendor neutral’ libglvnd option:

$ ll /usr/lib64/libGLX*
lrwxrwxrwx 1 root root 23 Jan 7 10:17 /usr/lib64/libGLX_indirect.so.0 -> libGLX_nvidia.so.361.16
lrwxrwxrwx 1 root root 23 Jan 7 10:17 /usr/lib64/libGLX_nvidia.so.0 -> libGLX_nvidia.so.361.16
-rwxr-xr-x 1 root root 1115368 Jan 7 10:17 /usr/lib64/libGLX_nvidia.so.361.16
lrwxrwxrwx 1 root root 11 Jan 7 10:17 /usr/lib64/libGLX.so -> libGLX.so.0
-rwxr-xr-x 1 root root 73352 Jan 7 10:17 /usr/lib64/libGLX.so.0

The install prompts to install the ‘complete’ libglvnd, but Plasma/KDE fails if you select the ‘install/overwrite’ option, and KDE5 fails with a ‘Could not start kdeinit5’ error if you select the ‘do not install’ option..

The workaround is to revert to driver 358.16..

This has already been covered in more detail on the NVIDIA forum..

https://devtalk.nvidia.com/default/topic/908506/many-essential-kde-applications-sddm-krunner-plasmashell-segfault-on-startup-with-361-16/

Robert Gadsdon.   January 7, 2016.

 


Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.