Kernel – 4.14-rc3 Released – OK with Patched VMware, Still has NVIDIA/AMD/GPL Problem..

Kernel 4.13-rc3 is out, and brief details of changes from -rc2 are here:  http://lkml.iu.edu/hypermail/linux/kernel/1710.0/00180.html

VMware 14.0.0 – with the vmmon patch – still loads/runs OK(*), and NVIDIA is OK on Intel systems, but if the new AMD ‘Secure Memory Encryption‘ feature is enabled in the kernel config, then NVIDIA (384.90) will still fail with a GPL error:

.............
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'sme_me_mask'
make[3]: *** [/usr/src/linux-4.14-rc3/scripts/Makefile.modpost:91: __modpost] Error 1
............

*  As expected, the ‘VMware 14 failing on older CPUs’  issue has produced quite a lot of ‘discussion’ on the VMware forum…

Robert Gadsdon.   October 1, 2017.


Comments

Kernel – 4.14-rc3 Released – OK with Patched VMware, Still has NVIDIA/AMD/GPL Problem.. — 2 Comments

  1. Hi

    which patches i have to use for Vmware 14? i have issue with vmmon ( memory errors ) when trying to run VMs whereas i have more than enough free memory in the system *(host)*

    Thanks

    Viktor

Leave a Reply

Your email address will not be published. Required fields are marked *