NVIDIA – New Driver – Same Problems..

NVIDIA have just released a new driver version – 384.90 – and brief details are here:  http://www.nvidia.com/Download/driverResults.aspx/123918/en-us

This version appears to be runtime bug-fixes only, and still fails to compile with Kernel 4.1.-rc1 without the patch mentioned in a previous article ( http://rglinuxtech.com/?p=2056 ), and still suffers from the GPL issue:

 .........
Building modules, stage 2.
 MODPOST 4 modules
FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'acpi_device_fwnode_ops'
make[3]: *** [/usr/src/linux-4.14-rc1/scripts/Makefile.modpost:91: __modpost] Error 1
make[2]: *** [/usr/src/linux-4.14-rc1/Makefile:1502: modules] Error 2
make[2]: Leaving directory '/usr/src/linux-4.14-rc1'
make[1]: *** [Makefile:145: sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-4.14-rc1'
make: *** [Makefile:81: modules] Error 2

There was some mention of a ‘completely new’ driver from NVIDIA some time ago, but this seems to have been forgotten, now..?

Robert Gadsdon.   September 21, 2017.


Leave a Reply

Your email address will not be published. Required fields are marked *